欢迎来到股票分析App——赢家江恩官网

当前位置:股票App > 投资常识 > 股票常识 > 正文

股票常识大全:MACD量线金叉指标公式详解

编辑:赢家江恩

2016-11-03 10:10:01

  初入股市的投资者学习了解最多的就是技术指标,比如是macd、kdj、rsi等都是可以研判个股买卖点以及趋势变化的实用性指标,当然也有部分的投资者喜欢借用股票行情App进行分析,其中最重要的是要明白指标公式的源码内容,下面金沙国际唯一官网网址通过macd量线金叉的指标公式源码进行讲解:

  

   首先,macd指标是有diff与dea两条线组成的,两线在低位形成金叉的形态是一种买入的信号,在高位形成死叉的状态是卖出点位,其具体的源码如下:

  DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORFFFFFF,LINETHICK1;

  DEA:EMA(DIFF,9),COLOR00FFFF,LINETHICK1;

  MACD:2*(DIFF-DEA), COLORSTICK;

  MACD1:2*(DIFF-DEA),COLORRED,LINETHICK0;

  MACD2:SMA(MACD1,0,3),COLORFFFF00,LINETHICK0;

  STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;

  STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLOR00FFFF;

  STICKLINE(MACD1< p=""><>

  S1:=MACD<0;

  S2:= (MACD>=0);

  S3:=BARSLAST(CROSS(DIFF,DEA));

  S4:=REF(S3,S3+1);

  S5:=DEA>REF(DEA,S4);

  S6:=DEA;

  上成立:=CROSS(DIFF,DEA) AND S5;

  下成立:=CROSS(DIFF,DEA) AND S6;

  L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));

  L2:=EMA(L1,9);

  L3:=BARSLAST(CROSS(L1,L2));

  L4:=REF(L3,L3+1);

  L5:=L2;

  变盘:CROSS(L1,L2) AND L5,LINETHICK0,COLORD6FF9C;

  STICKLINE(变盘,5,-5,4,1),COLORD6FF9C;

  成立距今:BARSLAST(CROSS(DIFF,DEA)),LINETHICK0;

  L6:=BARSCOUNT(CLOSE);

  DRAWTEXT(CROSS(L1,L2),DIFF,'买'),COLOR0000FF;

  DRAWTEXT(CROSS(L2,L1),DIFF,'卖'),COLORFFFF00;

  REF(DEA,S3),POINTDOT,COLORGREEN;

  IF(L1>L2,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORB078FF;

  IF(MACD<0,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORGREEN;

  LS:=IF(DIFF>DEA AND DIFF>0,1,0);

  加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);

  XG1:CROSS(MACD1,MACD2) AND MACD1<0,LINETHICK0;

  XG2:CROSS(DIFF,DEA),LINETHICK0;

  M1:=MACD>REF(MACD,1) AND DIFF< p=""><>

  绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,LINETHICK0;

  DRAWTEXT(绿柱短了,MACD,'绿柱短了'),COLOR00FF80;

  从源码公式中能够分辨出不同的指标点位操作方法是不同的,投资者需要注意的就是股价的变盘点位以及实战中个股加速上扬的启动点,把握好其中的操作机会。

  以上就是本文讲解的关于股市中macd指标源码的操作公式,主要是金叉买入信号的技巧,如果您还想要了解更加专业的技术分析常识或者是操作案例,请点击股票常识大全栏目进行学习了解,亨瑞App将为您提供一条完善的技术分析体系,帮助您在实战中获得投资经验。


赢家江恩财富网  www.360gann.com

XML 地图 | Sitemap 地图