欢迎来到股票分析App——赢家江恩官网

当前位置:股票App > 投资常识 > 股票常识 > 正文

低金顶背离指标公式详解(附源码)

编辑:赢家江恩

2016-10-29 10:28:10

  股市中听的最多的就是股价背离,指的是技术指标与股票价格K线走势的相反形态,不仅仅是可以通过股票行情App进行分析,还可以通过具体的指标公式源码进行解析,比如是今天要讲解的低金顶背离指标公式就是一种判断支撑和买卖点的操作工具。

  首先金沙国际唯一官网网址来学习一下低金顶背离指标公式的源码:

  DIF:(EMA(CLOSE,12) - EMA(CLOSE,26)),COLORRED,NODRAW;

  DEA:EMA(DIF,9),COLOR00FFFF,NODRAW;

  MACD:2*(DIF-DEA),NODRAW;

  DIFK:=EMA(DIF,3);

  DIFD:=EMA(DIFK,3);

  DKK:4*DIF-3*DEA,COLORFF00FF,NODRAW;

  DDD:EMA(DKK,5),COLOR2588FF,NODRAW;

  DRAWICON(CROSS(DDD,DKK),DKK,2);

  DRAWICON(CROSS(DKK,DDD),DDD,1);

  TRLSX1:= MAX(MAX((HHV(DIF,13)-LLV(DIF,13)),ABS(REF(DIF,1)-HHV(DIF,13))),ABS(REF(DIF,1)-LLV(DIF,13)));

  TRLSX2:=EMA(TRLSX1,13);

  TRLSX3:=REF(DIF,1)-REF(TRLSX2,1);

  支撑:HHV(TRLSX3,13),COLORFFFFFF,NODRAW;

  RSV14:=(CLOSE - LLV(LOW,14))/(HHV(HIGH,14) - LLV(LOW,14))-0.5;

  K14:=EMA(RSV14,3),COLORFF00FF,NODRAW;

  D14:=EMA(K14,3),COLORGREEN,NODRAW;

  J14:=3*K14-2*D14;

  DRAWBAND(DIF,RGB(200,50,55),DEA,RGB(50,100,10));

  STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR000055;

  STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR000099;

  STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR0000BB;

  STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR888888;

  STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLORBBBBBB;

  STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLORDDDDDD;

  STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR3377AA;

  STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR3388BB;

  STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR4499CC;

  STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLORFF3300;

  STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLORFF5500;

  STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLORFF7700;

  STICKLINE(J14<-0.5,0,0.15,1.8,0),COLORFF00FF;

  支撑,COLORFFFFFF;

  IF(C>0,DIF,DRAWNULL),COLORRED,LINETHICK1;

  IF(C>0,DEA,DRAWNULL),COLOR00FFFF,LINETHICK1;

  IF(DIF<=REF(DIF,1),DIF,DRAWNULL),COLORBLUE,LINETHICK1;

  IF(C,DKK,DRAWNULL),COLORFF00FF,LINETHICK1;

  IF(DKK<=REF(DKK,1),DKK,DRAWNULL),COLORCYAN,LINETHICK1;

  IF(C,DDD,DRAWNULL),COLOR2255FF,LINETHICK1;

  IF(DDD<=REF(DDD,1),DDD,DRAWNULL),COLOR33FF33,LINETHICK1;

  TS:=BARSLAST(MACD>=0 AND REF(MACD,1)<0);

  红柱面积:0.091*IF(MACD<0 AND REF(MACD,1)>=0,SUM(REF(MACD,1),TS),0),COLORMAGENTA,LINETHICK0;

  STICKLINE(MACD<0 AND REF(MACD,1)>=0,0,红柱面积,4,0),COLORWHITE;

  TS1:=BARSLAST(MACD<=0 AND REF(MACD,1)>0);

  绿柱面积:0.1*IF(MACD>0 AND REF(MACD,1)<=0,SUM(REF(MACD,1),TS1),0),COLORGREEN,LINETHICK0;

  STICKLINE(MACD>0 AND REF(MACD,1)<=0,0,绿柱面积,4,0),COLORGREEN;

  A1:=CROSS(DIF,DEA) AND DIF<-0.1;

  底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

  STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

  底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;

  DRAWTEXT(底背离,0.12, 底背离),COLORFF00FF;

  A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

  AA:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

  二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(AA=2,21)=1;

  DRAWTEXT(二次金叉,0.2, 二次金叉),COLORYELLOW;

  低金:=BARSLAST(REF(CROSS(DIF,DEA),1));

  STICKLINE(低金,0,0.01,6,0),COLORYELLOW;

  DRAWTEXT(低金,0.10, 低金),COLORWHITE;

  从源码中可以发现,与macd指标中的两条线应用方法类似,同样是寻找金叉和死叉的买卖点以及顶底背离的走势情况,当然该指标的源码公式还涉及了红绿柱的面积大小,希翼投资者能够积极的把握其中的操作机会。

  以上就是本文讲解的关于指标背离的公式源码,如果您还想要了解更加专业的技术分析常识,请点击股票基本常识大全,了解最新热门的概念股走势与行情变化。


赢家江恩财富网  www.360gann.com

XML 地图 | Sitemap 地图